Só funciona correctamente com o Internet Explorer (IE) até à versão 6 (incl.) Para ver os mapas necessita de instalar um programa. O IE instala-o na primeira vez que escolher um tema no índice. Se a instalação não for bem sucedida clique aqui e faça "Guardar destino como...". De seguida descompacte o ficheiro e execute a intalação do programa.